summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-04-22 14:33:57 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-11 21:57:24 +0200
commitafdfbb1dca302bbf958f039871da566aaf5947ac (patch)
tree7ef4f910ae5f0fe56edb3a59651ee73ba137fe17
parent1b16f1ecb19924899cf8d9831f6ebfd57143aec4 (diff)
downloadguix-afdfbb1dca302bbf958f039871da566aaf5947ac.tar.gz
gnu: Add python-elasticsearch.
* gnu/packages/python.scm (python-elasticsearch, python2-elasticsearch):
New variables.
-rw-r--r--gnu/packages/python.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2f2da39aac..b30fd1aabc 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14354,3 +14354,35 @@ especially -cover-package.")
 
 (define-public python2-nosexcover
   (package-with-python2 python-nosexcover))
+
+(define-public python-elasticsearch
+  (package
+    (name "python-elasticsearch")
+    (version "1.0.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "elasticsearch" version))
+        (sha256
+         (base32
+          "1sdw1r05cw7ihnmng8ra9v968fj7bq6sji8i1dikymsnkcpgc69g"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-mock" ,python-mock)
+       ("python-nosexcover" ,python-nosexcover)
+       ("python-pyaml" ,python-pyaml)
+       ("python-requests" ,python-requests)))
+    (propagated-inputs
+     `(("urllib3" ,python-urllib3)))
+    (arguments
+     ;; tests require the test_elasticsearch module but it is not distributed.
+     `(#:tests? #f))
+    (home-page "https://github.com/elastic/elasticsearch-py")
+    (synopsis "Low-level client for Elasticsearch")
+    (description "Official low-level client for Elasticsearch.  Its goal is to
+provide common ground for all Elasticsearch-related code in Python; because of
+this it tries to be opinion-free and very extendable.")
+    (license license:expat)))
+
+(define-public python2-elasticsearch
+  (package-with-python2 python-elasticsearch))