summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-06-29 22:18:05 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-06-29 22:41:27 +0300
commitb176f69fba492d36a0e0f86f8f1e6e55a7c22376 (patch)
tree3e8a1aa28684fda477153ab55ff3695b755a9bf1
parent02b38c112eb14705f2e1822ae69e89443a031399 (diff)
downloadguix-b176f69fba492d36a0e0f86f8f1e6e55a7c22376.tar.gz
gnu: java-guice: Don't use unstable tarball.
* gnu/packages/java.scm (java-guice)[source]: Download using git-fetch.
[arguments]: Add custom 'make-files-writable phase.
(java-guice-servlet)[arguments]: Same.
-rw-r--r--gnu/packages/java.scm33
1 files changed, 23 insertions, 10 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 48f9a52a56..1bec3fe6a8 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -9068,23 +9068,30 @@ the dependency is said to be unsatisfied, and the application is broken.")
     (name "java-guice")
     (version "4.1")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/google/guice/archive/"
-                                  version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/google/guice")
+                     (commit version)))
+              (file-name (git-file-name name version))
               (modules '((guix build utils)))
               (snippet
                `(begin
-                  (for-each delete-file (find-files "." ".*.jar"))))
+                  (for-each delete-file (find-files "." ".*.jar")) #t))
               (sha256
                (base32
-                "0dwmqjzlavb144ywqqglj3h68hqszkff8ai0a42hyb5il0qh4rbp"))))
+                "18im5hdfl4q1b9chww2s1ii60sn3ydyyar32a2sf2p2g8zlbdswq"))))
     (build-system ant-build-system)
     (arguments
      `(#:jar-name "java-guice.jar"
        #:jdk ,icedtea-8
-       #:tests? #f; FIXME: tests are not in a java sub directory
-       #:source-dir "core/src"))
+       #:tests? #f  ; FIXME: tests are not in a java sub directory
+       #:source-dir "core/src"
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'make-files-writable
+           (lambda _
+             (for-each make-file-writable (find-files "."))
+             #t)))))
     (inputs
      `(("guava" ,java-guava)
        ("java-cglib" ,java-cglib)
@@ -9093,7 +9100,7 @@ the dependency is said to be unsatisfied, and the application is broken.")
        ("java-asm" ,java-asm)))
     (home-page "https://github.com/google/guice")
     (synopsis "Lightweight dependency injection framework")
-    (description "Guice is a lightweight dependency injection framework fo
+    (description "Guice is a lightweight dependency injection framework for
 Java 6 and above.")
     (license license:asl2.0)))
 
@@ -9105,7 +9112,13 @@ Java 6 and above.")
      `(#:jar-name "guice-servlet.jar"
        #:source-dir "extensions/servlet/src/"
        #:jdk ,icedtea-8
-       #:tests? #f)); FIXME: not in a java subdir
+       #:tests? #f  ; FIXME: not in a java subdir
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'make-files-writable
+           (lambda _
+             (for-each make-file-writable (find-files "."))
+             #t)))))
     (inputs
      `(("guice" ,java-guice)
        ("servlet"  ,java-classpathx-servletapi)