summary refs log tree commit diff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2019-12-15 20:42:15 +0000
committerVagrant Cascadian <vagrant@debian.org>2019-12-15 13:01:10 -0800
commitbc685e1ca3516a218c083da206d3d1c354733073 (patch)
tree0ad57da4bd5b37943050934bed7f40558b786ee9
parent5487ddac2279d7d1200d558864d7c063a39de1c6 (diff)
downloadguix-bc685e1ca3516a218c083da206d3d1c354733073.tar.gz
gnu: diffoscope: Add support for zstd compression.
* gnu/packages/diffoscope (diffoscope)[native-inputs]: Add zstd.
  [arguments]: Add add-known-tools phase with support for zstd.
-rw-r--r--gnu/packages/diffoscope.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 821dc8aff9..93630f3bb6 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -90,6 +90,12 @@
                       (lambda _
                         (substitute* "setup.py"
                           (("'python-magic',") ""))))
+                    ;; Patch in support for known tools
+                    (add-after 'unpack 'add-known-tools
+                      (lambda _
+                        (substitute* "diffoscope/external_tools.py"
+                          (("'debian': 'zstd'")
+                           "'debian': 'zstd', 'guix': 'zstd'"))))
                     ;; This test is broken because our `file` package has a
                     ;; bug in berkeley-db file type detection.
                     (add-after 'unpack 'remove-berkeley-test
@@ -209,7 +215,8 @@
                        ("wabt" ,wabt)
                        ("xxd" ,xxd)
                        ("xz" ,xz)
-                       ("zip" ,zip)))
+                       ("zip" ,zip)
+                       ("zstd" ,zstd)))
       (home-page "https://diffoscope.org/")
       (synopsis "Compare files, archives, and directories in depth")
       (description