summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-06-20 13:13:00 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-06-20 13:14:16 +0200
commitbecb9cbfe1e2fb70da940e989f56be17abe31133 (patch)
tree8dbf7609edea29b05c5ee869a568aa3450e91d66
parent8e590c81539a79ec19bf91d3e5f8a2c4f9a659bb (diff)
downloadguix-becb9cbfe1e2fb70da940e989f56be17abe31133.tar.gz
gnu: python-jupyter-console: Update to 6.0.0.
* gnu/packages/python-xyz.scm (python-jupyter-console): Update to 6.0.0.
[arguments]: Enable tests.
[propagated-inputs]: Replace python-prompt-toolkit-1 with
python-prompt-toolkit.
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d3d3ef31d0..5e19cc9b5d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7567,21 +7567,19 @@ in the data.")
 (define-public python-jupyter-console
   (package
     (name "python-jupyter-console")
-    (version "5.2.0")
+    (version "6.0.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "jupyter_console" version))
        (sha256
         (base32
-         "1kam1qzgwr7srhm5r6aj90di5sws4bq0jmiw15452ddamb9yspal"))))
+         "1xdjw11cppf1fxvwkw2bk13ckkwas3bdah8baingn9296mvfi31h"))))
     (build-system python-build-system)
-    ;; Tests only run in an TTY.
-    (arguments `(#:tests? #f))
     (propagated-inputs
      `(("python-ipykernel" ,python-ipykernel)
        ("python-jupyter-client" ,python-jupyter-client)
-       ("python-prompt-toolkit" ,python-prompt-toolkit-1)
+       ("python-prompt-toolkit" ,python-prompt-toolkit)
        ("python-pygments" ,python-pygments)))
     (native-inputs
      `(("python-nose" ,python-nose)))