summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-06-28 14:46:08 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-06-28 14:59:30 +0300
commitd1514c9bba6b0991c04dc24e7d688ee57bb604d6 (patch)
treef099005c0f223c90be3c200e91d997194ccaa816
parent266fadf0111e6cc7b50fd9eafbba73a84c6c5665 (diff)
downloadguix-d1514c9bba6b0991c04dc24e7d688ee57bb604d6.tar.gz
gnu: Add rust-hmac-0.8.
* gnu/packages/crates-io.scm (rust-hmac-0.8): New variable.
(rust-hmac-0.7): Inherit from rust-hmac-0.8.
-rw-r--r--gnu/packages/crates-io.scm39
1 files changed, 31 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c1a4b68f4a..0fcfffd0e8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -9935,10 +9935,10 @@ compile time.")
      `(#:cargo-inputs
        (("rust-proc-macro-hack" ,rust-proc-macro-hack-0.4))))))
 
-(define-public rust-hmac-0.7
+(define-public rust-hmac-0.8
   (package
     (name "rust-hmac")
-    (version "0.7.1")
+    (version "0.8.1")
     (source
       (origin
         (method url-fetch)
@@ -9947,16 +9947,16 @@ compile time.")
          (string-append name "-" version ".tar.gz"))
         (sha256
          (base32
-          "15cnwpssp2n1kdm9x7abir67f2hp3q6rdfj1mcck3hm4rmj5xjsx"))))
+          "0h48wc7iysh4xd6ci4prh8bb7nszijrh9w3blaaq8a6cilk8hs0j"))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
-       (("rust-crypto-mac" ,rust-crypto-mac-0.7)
-        ("rust-digest" ,rust-digest-0.8))
+       (("rust-crypto-mac" ,rust-crypto-mac-0.8)
+        ("rust-digest" ,rust-digest-0.9))
        #:cargo-development-inputs
-       (("rust-crypto-mac" ,rust-crypto-mac-0.7)
-        ("rust-md-5" ,rust-md-5-0.8)
-        ("rust-sha2" ,rust-sha2-0.8))))
+       (("rust-crypto-mac" ,rust-crypto-mac-0.8)
+        ("rust-md-5" ,rust-md-5-0.9)
+        ("rust-sha2" ,rust-sha2-0.9))))
     (home-page "https://github.com/RustCrypto/MACs")
     (synopsis "Generic implementation of Hash-based Message Authentication Code")
     (description
@@ -9964,6 +9964,29 @@ compile time.")
 Hash-based Message Authentication Code}.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-hmac-0.7
+  (package
+    (inherit rust-hmac-0.8)
+    (name "rust-hmac")
+    (version "0.7.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "hmac" version))
+        (file-name
+         (string-append name "-" version ".tar.gz"))
+        (sha256
+         (base32
+          "15cnwpssp2n1kdm9x7abir67f2hp3q6rdfj1mcck3hm4rmj5xjsx"))))
+    (arguments
+     `(#:cargo-inputs
+       (("rust-crypto-mac" ,rust-crypto-mac-0.7)
+        ("rust-digest" ,rust-digest-0.8))
+       #:cargo-development-inputs
+       (("rust-crypto-mac" ,rust-crypto-mac-0.7)
+        ("rust-md-5" ,rust-md-5-0.8)
+        ("rust-sha2" ,rust-sha2-0.8))))))
+
 (define-public rust-hostname-0.1
   (package
     (name "rust-hostname")