summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-11 12:04:45 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-17 14:00:16 +0200
commitd770d07fb5249a852b4043f4cde80505fd45fc39 (patch)
tree4f2b765877de789532941b82826c94e05f960a5a
parent8c23f238e9563fafc9cd06d52717bdb2a2cbfe65 (diff)
downloadguix-d770d07fb5249a852b4043f4cde80505fd45fc39.tar.gz
gnu: Add texlive-latex-psfrag.
* gnu/packages/tex.scm (texlive-latex-psfrag): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1a1bfdf31a..04dbc410ca 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1931,6 +1931,31 @@ that are compatible with @code{natbib}: @code{plainnat}, @code{unsrtnat},
 designed from the start to be compatible with @code{natbib}.")
     (license license:lppl)))
 
+(define-public texlive-latex-psfrag
+  (package
+    (name "texlive-latex-psfrag")
+    (version (number->string %texlive-revision))
+    (source (origin
+              (method svn-fetch)
+              (uri (texlive-ref "latex" "psfrag"))
+              (file-name (string-append name "-" version "-checkout"))
+              (sha256
+               (base32
+                "1dxbl5il7wbbsp0v45vk884xi1192wxw03849pb1g5q4x808n352"))))
+    (build-system texlive-build-system)
+    (arguments '(#:tex-directory "latex/psfrag"))
+    (home-page "http://www.ctan.org/pkg/psfrag")
+    (synopsis "Replace strings in encapsulated PostScript figures")
+    (description
+     "This package allows LaTeX constructions (equations, picture
+environments, etc.) to be precisely superimposed over Encapsulated PostScript
+figures, using your own favorite drawing tool to create an EPS figure and
+placing simple text \"tags\" where each replacement is to be placed, with
+PSfrag automatically removing these tags from the figure and replacing them
+with a user specified LaTeX construction, properly aligned, scaled, and/or
+rotated.")
+    (license (license:fsf-free "file://psfrag.dtx"))))
+
 (define-public texlive-latex-seminar
   (package
     (name "texlive-latex-seminar")