summary refs log tree commit diff
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2020-06-16 16:25:37 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-06-16 16:33:55 +0200
commite23ec7144c264902ac13fa75e01a206e4d907e5a (patch)
treeaf1535df22739a3306b49632ceb6cbffaab40888
parent619972f7b5dc34457ad9c474bf8f9f98786d70e0 (diff)
downloadguix-e23ec7144c264902ac13fa75e01a206e4d907e5a.tar.gz
gnu: libmateweather: Fix tests.
Apply the following upstream fix:
https://github.com/mate-desktop/libmateweather/commit/ea13e06563fb5fa53f8a9643156a64825e986acb.

* gnu/packages/mate.scm (libmateweather)[source]: Fix tests by renaming
America/Godthab timezone to America/Nuuk.
-rw-r--r--gnu/packages/mate.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 8b548b5d8e..864fa8dc18 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -6,6 +6,7 @@
 ;;; Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2019 Guy Fleury Iteriteka <hoonandon@gmail.com>
 ;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -264,7 +265,16 @@ desktop and the mate-about program.")
                            name "-" version ".tar.xz"))
        (sha256
         (base32
-         "094mnlczxq9crjj8z7dzs1zmwscdkbp54l3qjaf4a4bhd8lihv8d"))))
+         "094mnlczxq9crjj8z7dzs1zmwscdkbp54l3qjaf4a4bhd8lihv8d"))
+       (modules '((guix build utils)))
+       ;; This is fixed by commit ea13e065 upstream. Remove this once 1.25.0
+       ;; is out.
+       (snippet
+        '(begin
+           (substitute* "data/Locations.xml.in"
+             (("Godthab")
+              "Nuuk"))
+           #t))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags