summary refs log tree commit diff
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-10-18 03:07:37 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-22 15:32:16 -0700
commite329bacb850130d49a1973cdcc6086e7b4257809 (patch)
treeeebd456ed5527681ae6d35168f9b187c112dfe6e
parentac4cb8fd7a94f7ba1892bbca197b5940d4dbe524 (diff)
downloadguix-e329bacb850130d49a1973cdcc6086e7b4257809.tar.gz
gnu: Add ghc-tuple-th.
* gnu/packages/haskell.scm (ghc-tuple-th): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 7eb6946627..31edf24485 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9469,4 +9469,26 @@ Therefore it's recommended for the users of @code{ghc-base-prelude} to specify
 the bounds of \"base\" as well.")
     (license license:expat)))
 
+(define-public ghc-tuple-th
+  (package
+    (name "ghc-tuple-th")
+    (version "0.2.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "tuple-th-" version "/"
+                           "tuple-th-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1mrl4vvxmby7sf1paf7hklzidnr6wq55822i73smqyz0xpf3gsjn"))))
+    (build-system haskell-build-system)
+    (home-page "https://github.com/DanielSchuessler/tuple-th")
+    (synopsis "Generate utility functions for tuples of statically known size
+for Haskell")
+    (description "This Haskell package contains Template Haskell functions for
+generating functions similar to those in @code{Data.List} for tuples of
+statically known size.")
+    (license license:bsd-3)))
+
 ;;; haskell.scm ends here