summary refs log tree commit diff
diff options
context:
space:
mode:
authorJohn Doe <dftxbs3e@free.fr>2020-12-27 23:26:47 +0100
committerEfraim Flashner <efraim@flashner.co.il>2020-12-28 13:21:13 +0200
commitef5df1588cd4d38da9692b8cd44ffcae679eb6e8 (patch)
treebbb29b3eb406b56a2af14c2e3c24f851644b34bf
parenta942ab183782bbdf785bd73f70f7ec905764f941 (diff)
downloadguix-ef5df1588cd4d38da9692b8cd44ffcae679eb6e8.tar.gz
gnu: Add python-helpdev.
* gnu/packages/python-xyz.scm (python-helpdev): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b8182fbe08..8ff0090971 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23251,3 +23251,25 @@ backport of the @code{dataclasses} module for Python 3.6.")
     (description "@code{python-pywatchman} is a library to connect and
 query Watchman to discover file changes.")
     (license license:bsd-3)))
+
+(define-public python-helpdev
+  (package
+    (name "python-helpdev")
+    (version "0.7.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "helpdev" version))
+        (sha256
+         (base32
+          "0gfvj28i82va7c264jl2p4cdsl3lpf9fpb9cyjnis55crfdafqmv"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-importlib-metadata" ,python-importlib-metadata)))
+    (home-page "https://gitlab.com/dpizetta/helpdev")
+    (synopsis
+     "Extract information about the Python environment easily")
+    (description
+     "Helpdev is a library to easily extract information about the Python
+environment.")
+    (license license:expat)))