summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-03 20:18:52 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-06 18:38:00 +0100
commitf0e810110bf44b6c5c61bf0cdcadc836a7fd459d (patch)
tree793b32a4f078adbec3cbf8eaf6b467aefe19e2cb
parentfe994a0c328b456195fcf64443c28b2ca3f8da76 (diff)
downloadguix-f0e810110bf44b6c5c61bf0cdcadc836a7fd459d.tar.gz
gnu: WebKitGTK: Remove obsolete patch.
This patch was added in eb5f3ea1003f76545b197b1e779e2967ec379475 and no longer
necessary since the update to 2.26.3 in f32ca55778eb049e83210aedcbeb4df2c98e587a.

* gnu/packages/patches/webkitgtk-icu-65.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/webkit.scm (webkitgtk)[source](patches): Remove.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/webkitgtk-icu-65.patch47
-rw-r--r--gnu/packages/webkit.scm1
3 files changed, 0 insertions, 49 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 65b62e2e58..60b1ce9248 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1480,7 +1480,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/vte-CVE-2012-2738-pt1.patch			\
   %D%/packages/patches/vte-CVE-2012-2738-pt2.patch			\
   %D%/packages/patches/weasyprint-library-paths.patch		\
-  %D%/packages/patches/webkitgtk-icu-65.patch			\
   %D%/packages/patches/websocketpp-fix-for-boost-1.70.patch	\
   %D%/packages/patches/wicd-bitrate-none-fix.patch		\
   %D%/packages/patches/wicd-get-selected-profile-fix.patch	\
diff --git a/gnu/packages/patches/webkitgtk-icu-65.patch b/gnu/packages/patches/webkitgtk-icu-65.patch
deleted file mode 100644
index 66819c566b..0000000000
--- a/gnu/packages/patches/webkitgtk-icu-65.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-Fix build with ICU 65.
-
-Taken from upstream:
-https://bugs.webkit.org/show_bug.cgi?id=202600
-https://trac.webkit.org/r250747
-
-diff --git a/Source/WTF/wtf/URLHelpers.cpp b/Source/WTF/wtf/URLHelpers.cpp
-index 18e7f13cd615..c584f1a0cb7e 100644
---- a/Source/WTF/wtf/URLHelpers.cpp
-+++ b/Source/WTF/wtf/URLHelpers.cpp
-@@ -301,7 +301,7 @@ static bool allCharactersInIDNScriptWhiteList(const UChar* buffer, int32_t lengt
-     Optional<UChar32> previousCodePoint;
-     while (i < length) {
-         UChar32 c;
--        U16_NEXT(buffer, i, length, c)
-+        U16_NEXT(buffer, i, length, c);
-         UErrorCode error = U_ZERO_ERROR;
-         UScriptCode script = uscript_getScript(c, &error);
-         if (error != U_ZERO_ERROR) {
-diff --git a/Source/WebCore/dom/Document.cpp b/Source/WebCore/dom/Document.cpp
-index 2443e24c9bc4..1fbb3a716006 100644
---- a/Source/WebCore/dom/Document.cpp
-+++ b/Source/WebCore/dom/Document.cpp
-@@ -4954,12 +4954,12 @@ static bool isValidNameNonASCII(const UChar* characters, unsigned length)
-     unsigned i = 0;
- 
-     UChar32 c;
--    U16_NEXT(characters, i, length, c)
-+    U16_NEXT(characters, i, length, c);
-     if (!isValidNameStart(c))
-         return false;
- 
-     while (i < length) {
--        U16_NEXT(characters, i, length, c)
-+        U16_NEXT(characters, i, length, c);
-         if (!isValidNamePart(c))
-             return false;
-     }
-@@ -5019,7 +5019,7 @@ ExceptionOr<std::pair<AtomString, AtomString>> Document::parseQualifiedName(cons
- 
-     for (unsigned i = 0; i < length; ) {
-         UChar32 c;
--        U16_NEXT(qualifiedName, i, length, c)
-+        U16_NEXT(qualifiedName, i, length, c);
-         if (c == ':') {
-             if (sawColon)
-                 return Exception { InvalidCharacterError };
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index b3a87e798a..aeead92871 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -126,7 +126,6 @@ engine that uses Wayland for graphics output.")
               (method url-fetch)
               (uri (string-append "https://www.webkitgtk.org/releases/"
                                   "webkitgtk-" version ".tar.xz"))
-              (patches (search-patches "webkitgtk-icu-65.patch"))
               (sha256
                (base32
                 "04g6y0sv04d20bw401myq3k828ikysjhx383ly81vh9wji9i3mdd"))))