summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-24 14:36:48 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-26 20:13:11 +0100
commitfc38e317cde56897b575c5af2d7787d889323193 (patch)
treede7018557ddb6383f79ec379c4ea3a702e2defda
parentb737530569844d1538a45f209460fedc0edf7497 (diff)
downloadguix-fc38e317cde56897b575c5af2d7787d889323193.tar.gz
gnu: python-cffi: Update phase style.
* gnu/packages/libffi.scm (python-cffi)[arguments]: Substitute INVOKE
for SYSTEM*, end phases with #t, and remove unneeded bits from the
‘install-doc’ phase.
-rw-r--r--gnu/packages/libffi.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/libffi.scm b/gnu/packages/libffi.scm
index e5e93eb916..dd6b2237f9 100644
--- a/gnu/packages/libffi.scm
+++ b/gnu/packages/libffi.scm
@@ -122,7 +122,8 @@ conversions for values passed between the two languages.")
                                "linker_so='gcc -shared')")))
              (substitute* "testing/cffi0/test_ownlib.py"
                (("'cc testownlib") "'gcc testownlib"))
-             (zero? (system* "py.test" "-v" "c/" "testing/"))))
+             (invoke "py.test" "-v" "c/" "testing/")
+             #t))
          (add-before 'check 'disable-failing-test
            ;; This is assumed to be a libffi issue:
            ;; https://bitbucket.org/cffi/cffi/issues/312/tests-failed-with-armv8
@@ -131,15 +132,14 @@ conversions for values passed between the two languages.")
                (("ret.left") "ownlib.left"))
              #t))
          (add-after 'install 'install-doc
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((data (string-append (assoc-ref outputs "doc") "/share"))
-                    (doc (string-append data "/doc/" ,name "-" ,version))
+           (lambda* (#:key outputs (make-flags '())  #:allow-other-keys)
+             (let* ((doc (string-append (assoc-ref outputs "doc")
+                                        "/share/doc/" ,name "-" ,version))
                     (html (string-append doc "/html")))
                (with-directory-excursion "doc"
-                 (system* "make" "html")
+                 (apply invoke "make" "html" make-flags)
                  (mkdir-p html)
                  (copy-recursively "build/html" html))
-               (copy-file "LICENSE" (string-append doc "/LICENSE"))
                #t))))))
     (home-page "https://cffi.readthedocs.org")
     (synopsis "Foreign function interface for Python")