summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-20 12:39:50 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-03-24 14:58:47 +0100
commit19ee92014488fe7037477dbe0b1999feae9ac59c (patch)
tree9a98d5ec832a22581b5008d1b8fb339248f6b952
parente2e21359c5930b9defec7e1359018347bc025850 (diff)
downloadguix-19ee92014488fe7037477dbe0b1999feae9ac59c.tar.gz
gnu: Add python2-pbcore.
* gnu/packages/bioinformatics.scm (python2-pbcore): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1214a0b708..fc0ce4a166 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -615,6 +615,35 @@ RNA-Seq, the MISO model uses Bayesian inference to compute the probability
 that a read originated from a particular isoform.")
     (license license:gpl2)))
 
+(define-public python2-pbcore
+  (package
+    (name "python2-pbcore")
+    (version "0.9.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/PacificBiosciences/pbcore/archive/"
+                    version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1z46rwjac93jm87cbj2zgjg6qvsgs65140wkbbxsvxps7ai4pm09"))))
+    (build-system python-build-system)
+    (arguments `(#:python ,python-2)) ; pbcore requires Python 2.7
+    (inputs
+     `(("python-cython" ,python2-cython)
+       ("python-numpy" ,python2-numpy)
+       ("python-pysam" ,python2-pysam)
+       ("python-h5py" ,python2-h5py)))
+    (native-inputs
+     `(("python-setuptools" ,python2-setuptools)))
+    (home-page "http://pacificbiosciences.github.io/pbcore/")
+    (synopsis "Library for reading and writing PacBio data files")
+    (description
+     "The pbcore package provides Python APIs for interacting with PacBio data
+files and writing bioinformatics applications.")
+    (license license:bsd-3)))
+
 (define-public rseqc
   (package
     (name "rseqc")