summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-19 20:55:13 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-19 22:33:30 +0200
commit25d39a2a2c3bc9b67f948004923bf7fe6ce8336f (patch)
tree6b921d77f6d9810638fecabcf47844c3bd8dabfa
parent6956867056148e897f737c2a44c520290a709e84 (diff)
downloadguix-25d39a2a2c3bc9b67f948004923bf7fe6ce8336f.tar.gz
gnu: librsvg-next: Inherit from librsvg.
* gnu/packages/gnome.scm (librsvg-next)[inherit]: New field, inherit
from librsvg.
-rw-r--r--gnu/packages/gnome.scm22
1 files changed, 1 insertions, 21 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6415171904..c39b4467b9 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2187,6 +2187,7 @@ library.")
 
 (define-public librsvg-next
   (package
+    (inherit librsvg)
     (name "librsvg")
     (version "2.46.4")
     (source (origin
@@ -2315,27 +2316,6 @@ library.")
                            ;; This test fails on aarch64:
                            "bugs/777834-empty-text-children.svg")))
              #t)))))
-    (native-inputs
-     `(("pkg-config" ,pkg-config)
-       ("vala" ,vala)
-       ("glib" ,glib "bin")                               ; glib-mkenums, etc.
-       ("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc.
-    (inputs
-     `(("pango" ,pango)
-       ("libcroco" ,libcroco)
-       ("bzip2" ,bzip2)
-       ("libgsf" ,libgsf)
-       ("libxml2" ,libxml2)))
-    (propagated-inputs
-     ;; librsvg-2.0.pc refers to all of that.
-     `(("cairo" ,cairo)
-       ("gdk-pixbuf" ,gdk-pixbuf)
-       ("glib" ,glib)))
-    (home-page "https://wiki.gnome.org/LibRsvg")
-    (synopsis "Render SVG files using Cairo")
-    (description
-     "Librsvg is a C library to render SVG files using the Cairo 2D graphics
-library.")
     (license license:lgpl2.1+)))
 
 (define-public libidl