summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-19 21:37:28 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-19 21:39:32 -0500
commit40b084a32679a59061f736b8f199f86eda42fd1f (patch)
treed009aac2af67af6cd03f2b806a1cb0aa745319d8
parent61c21ad31994954c6c4467353afd1960ae0573a1 (diff)
downloadguix-40b084a32679a59061f736b8f199f86eda42fd1f.tar.gz
gnu: Adjust latest perl modules to new 'modify-phases' syntax.
* gnu/packages/compression.scm (perl-compress-raw-zlib)[arguments]:
  Add missing quotes, as needed since commit f8503e2.
* gnu/packages/perl.scm (perl-ipc-run)[arguments]: Likewise.
* gnu/packages/xml.scm (perl-xml-sax)[arguments]: Likewise.
-rw-r--r--gnu/packages/compression.scm2
-rw-r--r--gnu/packages/perl.scm2
-rw-r--r--gnu/packages/xml.scm2
3 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 234ea338a1..4684fce130 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -385,7 +385,7 @@ compression library.")
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (add-before
-                   configure configure-zlib
+                   'configure 'configure-zlib
                    (lambda* (#:key inputs #:allow-other-keys)
                      (call-with-output-file "config.in"
                        (lambda (port)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 723b6d2d72..e55eb8791d 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2486,7 +2486,7 @@ pseudo ttys.")
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (add-before
-                   check disable-w32-test
+                   'check 'disable-w32-test
                    (lambda _
                      ;; This test fails, and we're not really interested in
                      ;; it, so disable it.
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 739f3fc384..d30c40ce1a 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -245,7 +245,7 @@ checks.")
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (add-before
-                   install augment-path
+                   'install 'augment-path
                    ;; The install target tries to load the newly-installed
                    ;; XML::SAX module, but can't find it, so we need to tell
                    ;; perl where to look.