summary refs log tree commit diff
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2021-01-16 17:52:25 +0000
committerLeo Famulari <leo@famulari.name>2021-02-01 19:54:35 -0500
commit4bce3a06b18f6924d69d62b2e898a5bc4917f411 (patch)
treef50518591f6171f47572051b1baf82959b751a93
parent5ecc09551b0394e59406ef7898bc084236d84c97 (diff)
downloadguix-4bce3a06b18f6924d69d62b2e898a5bc4917f411.tar.gz
gnu: ztoolkit: Move dependencies to propagated-inputs.
* gnu/packages/audio.scm (ztoolkit):[inputs]: Remove cairo, libx11.
[propagated-inputs]: Add cairo, libx11.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/audio.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 2e46dc3a26..9a9168c2d4 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -4829,11 +4829,13 @@ with the provided metadata and adhere to well-known best practices.")
         (base32
          "07xl3cmdaf7k9mm58m93cn8i1jvgimmiifdw1w7v2jl88nx60pm1"))))
     (build-system meson-build-system)
-    (inputs
-     `(("cairo" ,cairo)
-       ("libx11" ,libx11)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
+    ;; These are listed as propagated inputs because they are dependencies
+    ;; in pkgconfig.
+    (propagated-inputs
+     `(("cairo" ,cairo)
+       ("libx11" ,libx11)))
     (synopsis "GUI toolkit for LV2 plugins")
     (description "ZToolkit (Ztk) is a cross-platform GUI toolkit heavily
 inspired by GTK.  It handles events and low level drawing on behalf of