summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-03-13 16:16:53 -0400
committerLeo Famulari <leo@famulari.name>2019-03-14 15:34:28 -0400
commit56f610f5c753d56f8c773252bd3c1f07a5c91442 (patch)
tree84240ff770c8dc88c0d21fb89f26f9a8d614c3bf
parent4e9e74be074f6c270e30b4fa8a7f54e5f989358c (diff)
downloadguix-56f610f5c753d56f8c773252bd3c1f07a5c91442.tar.gz
gnu: Add go-github-com-kr-text.
* gnu/packages/golang.scm (go-github-com-kr-text): New variable.
-rw-r--r--gnu/packages/golang.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 5e21d87946..cf162de854 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3104,3 +3104,24 @@ have super fancy logs.")
       (description "This package provides a library for parsing the dotenv
 format in Go.")
       (license license:expat))))
+
+(define-public go-github-com-kr-text
+  (package
+    (name "go-github-com-kr-text")
+    (version "0.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/kr/text.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1gm5bsl01apvc84bw06hasawyqm4q84vx1pm32wr9jnd7a8vjgj1"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/kr/text"))
+    (synopsis "Text formatting in Go")
+    (description "This package provides a text formatting functions in Go.")
+    (home-page "https://github.com/kr/text")
+    (license license:expat)))