summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-05-10 13:12:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-05-10 13:31:03 +0200
commit5865606459d018758be55f31f8fa4b1f849fa74e (patch)
tree032257b9d3881c251a6354567307301046e08e94
parent144415391344ca7118268889867a00a5e5b5b466 (diff)
downloadguix-5865606459d018758be55f31f8fa4b1f849fa74e.tar.gz
gnu: Add r-rhisat2.
* gnu/packages/bioconductor.scm (r-rhisat2): New variable.
-rw-r--r--gnu/packages/bioconductor.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index fce157a516..e534b33555 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -24,6 +24,7 @@
   #:use-module (guix download)
   #:use-module (guix build-system r)
   #:use-module (gnu packages)
+  #:use-module (gnu packages base)
   #:use-module (gnu packages bioinformatics)
   #:use-module (gnu packages cran)
   #:use-module (gnu packages compression)
@@ -4433,3 +4434,31 @@ at the start or end of each splice variant.  The software includes functions
 for splice event prediction, quantification, visualization and
 interpretation.")
     (license license:artistic2.0)))
+
+(define-public r-rhisat2
+  (package
+    (name "r-rhisat2")
+    (version "1.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "Rhisat2" version))
+       (sha256
+        (base32
+         "1d1gwl8l2z8kzfvkp1s8vfrh6jbq9ha25dplpf9g62qqa8a46hga"))))
+    (properties `((upstream-name . "Rhisat2")))
+    (build-system r-build-system)
+    (native-inputs
+     `(("which" ,which)))
+    (propagated-inputs
+     `(("r-genomicfeatures" ,r-genomicfeatures)
+       ("r-genomicranges" ,r-genomicranges)
+       ("r-sgseq" ,r-sgseq)))
+    (home-page "https://github.com/fmicompbio/Rhisat2")
+    (synopsis "R Wrapper for HISAT2 sequence aligner")
+    (description
+     "This package provides an R interface to the HISAT2 spliced short-read
+aligner by Kim et al. (2015).  The package contains wrapper functions to
+create a genome index and to perform the read alignment to the generated
+index.")
+    (license license:gpl3)))