summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-04-27 22:09:15 +0200
committerAndreas Enge <andreas@enge.fr>2015-04-27 22:12:18 +0200
commit7b4570b4fb842932dbc64d8cd2608b37c9cb359d (patch)
treef916e24437a82ddafabc6f8f75602685b3dd30d0
parent67fa7a27fb5dfe2cdc01551c20f08c695d4dbe46 (diff)
downloadguix-7b4570b4fb842932dbc64d8cd2608b37c9cb359d.tar.gz
gnu: Add ixion.
* gnu/packages/libreoffice.scm: New file.
* gnu-system.am (GNU_SYSTEM_MODULES): Add it.

Co-authored-by: John Darrington <jmd@gnu.org>
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/libreoffice.scm52
2 files changed, 53 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index ae6b4e2bab..617e8bb217 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -175,6 +175,7 @@ GNU_SYSTEM_MODULES =				\
   gnu/packages/libftdi.scm			\
   gnu/packages/libidn.scm			\
   gnu/packages/libphidget.scm			\
+  gnu/packages/libreoffice.scm			\
   gnu/packages/libsigsegv.scm			\
   gnu/packages/libunistring.scm			\
   gnu/packages/libusb.scm			\
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
new file mode 100644
index 0000000000..97b464d0bc
--- /dev/null
+++ b/gnu/packages/libreoffice.scm
@@ -0,0 +1,52 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2014 John Darrington <jmd@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages libreoffice)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module ((guix licenses) #:select (mpl2.0))
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages boost)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages python))
+
+(define-public ixion
+  (package
+    (name "ixion")
+    (version "0.9.1")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "http://kohei.us/files/ixion/src/libixion-"
+                          version ".tar.xz"))
+      (sha256 (base32
+               "18g3nk29ljiqbyi0ml49j2x3f3xrqckdm9i66sw5fxnj7hb5rqvp"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+     (inputs
+      `(("mdds" ,mdds)
+        ("python" ,python-2))) ; looks for python.pc, not python3.pc
+    (home-page "https://gitlab.com/ixion/ixion")
+    (synopsis "General purpose formula parser and interpreter")
+    (description "Ixion is a library for calculating the results of formula
+expressions stored in multiple named targets, or \"cells\".  The cells can
+be referenced from each other, and the library takes care of resolving
+their dependencies automatically upon calculation.")
+    (license mpl2.0)))