summary refs log tree commit diff
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2019-07-21 16:55:33 +0200
committerJelle Licht <jlicht@fsfe.org>2019-08-21 14:14:29 +0200
commit8d3bc0f16508a5d76351245fbd08e930fcf5e586 (patch)
treef51aa37dce4718531d3ac501fda40d8e08c6d2bd
parenteb936efb2a23feb9ffa6ba4a79dc0451ec07732d (diff)
downloadguix-8d3bc0f16508a5d76351245fbd08e930fcf5e586.tar.gz
gnu: Add emacs-flyspell-correct.
* gnu/packages/emacs-xyz.scm (emacs-flyspell-correct): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a51545c3b3..a4a2164354 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -52,6 +52,7 @@
 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autitici.org>
 ;;; Copyright © 2019 Jens Mølgaard <jens@zete.tk>
 ;;; Copyright © 2019 Amin Bandali <bandali@gnu.org>
+;;; Copyright © 2019 Jelle Licht <jlicht@fsfe.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -17527,3 +17528,32 @@ Emacs Lisp's (relatively new) EIEIO object oriented libraries.")
 language-specific refactoring in Emacs.  It includes refactoring commands for
 a variety of languages, including elisp itself.")
     (license license:gpl3+)))
+
+(define-public emacs-flyspell-correct
+  (package
+    (name "emacs-flyspell-correct")
+    (version "0.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/d12frosted/flyspell-correct.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1r9hmz7sihhy7npv6nxp04sy57glzmfax5d67mwn96fdnc0yhlnd"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-helm" ,emacs-helm)
+       ("emacs-ivy" ,emacs-ivy)
+       ("emacs-popup" ,emacs-popup)))
+    (home-page
+     "https://github.com/d12frosted/flyspell-correct")
+    (synopsis
+     "Correcting words with flyspell via custom interfaces")
+    (description
+     "This package provides functionality for correcting words via custom
+interfaces.  Several interfaces are supported beside the classic ido: popup,
+helm and ivy.")
+    (license license:gpl3+)))