summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-03-13 16:57:55 -0400
committerLeo Famulari <leo@famulari.name>2019-03-14 15:34:30 -0400
commite3f14f47ffcbefa3c37910403f73e556524265ca (patch)
treec888669235d05e929547041bb7cd6bdb869321ad
parentc83f9f661dab95e1387afaece7b8b7c6189aebba (diff)
downloadguix-e3f14f47ffcbefa3c37910403f73e556524265ca.tar.gz
gnu: Add go-github-com-gogo-protobuf-gogoproto.
* gnu/packages/golang.scm (go-github-com-gogo-protobuf-gogoproto): New variable.
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cffe6227cc..1211827dc3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2316,6 +2316,30 @@ generation features.  This code generation is used to achieve:
       (home-page "https://github.com/gogo/protobuf")
       (license license:bsd-3))))
 
+(define-public go-github-com-gogo-protobuf-gogoproto
+  (package
+    (name "go-github-com-gogo-protobuf-gogoproto")
+    (version "1.2.1")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/gogo/protobuf.git")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "06yqa6h0kw3gr5pc3qmas7f7435a96zf7iw7p0l00r2hqf6fqq6m"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:unpack-path "github.com/gogo/protobuf"
+       #:import-path "github.com/gogo/protobuf/gogoproto"))
+    (home-page "https://github.com/gogo/protobuf")
+    (synopsis "Extensions to protocol buffers")
+    (description "This package provides extensions to the Gogo protocol buffers
+implementation.")
+    (license license:bsd-3)))
+
 (define-public go-github-com-gogo-protobuf-proto
   (let ((commit
           "fd322a3c49630fe6d05737e2b7d9426e6680e28d")