summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-04-10 05:34:17 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-04-10 05:38:44 +0300
commit1803f2493ebe3baf0ce1ce279372e0396c02b76f (patch)
tree3c111e171aa20427ac4ce059d3116bacdc5eb1ae
parent47fb74aebc45005d8045f81e69d2c69da31621f0 (diff)
downloadguix-1803f2493ebe3baf0ce1ce279372e0396c02b76f.tar.gz
gnu: gcl: Use 'modify-phases' syntax.
* gnu/packages/lisp.scm (gcl)[arguments]: Use 'modify-phases' syntax.
-rw-r--r--gnu/packages/lisp.scm41
1 files changed, 20 insertions, 21 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 6246840afa..fc78a60f18 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -88,27 +88,26 @@
      `(#:parallel-build? #f  ; The build system seems not to be thread safe.
        #:tests? #f  ; There does not seem to be make check or anything similar.
        #:configure-flags '("--enable-ansi") ; required for use by the maxima package
-       #:phases (alist-cons-before
-                'configure 'pre-conf
-                (lambda _
-                  (substitute*
-                      (append
-                       '("pcl/impl/kcl/makefile.akcl"
-                         "add-defs"
-                         "unixport/makefile.dos"
-                         "add-defs.bat"
-                         "gcl-tk/makefile.prev"
-                         "add-defs1")
-                       (find-files "h" "\\.defs"))
-                    (("SHELL=/bin/bash")
-                     (string-append "SHELL=" (which "bash")))
-                    (("SHELL=/bin/sh")
-                     (string-append "SHELL=" (which "sh"))))
-                  #t)
-                ;; drop strip phase to make maxima build, see
-                ;; https://www.ma.utexas.edu/pipermail/maxima/2008/009769.html
-                (alist-delete 'strip
-                 %standard-phases))))
+       #:phases (modify-phases %standard-phases
+                  (add-before 'configure 'pre-conf
+                    (lambda _
+                      (substitute*
+                        (append
+                         '("pcl/impl/kcl/makefile.akcl"
+                           "add-defs"
+                           "unixport/makefile.dos"
+                           "add-defs.bat"
+                           "gcl-tk/makefile.prev"
+                           "add-defs1")
+                         (find-files "h" "\\.defs"))
+                        (("SHELL=/bin/bash")
+                         (string-append "SHELL=" (which "bash")))
+                        (("SHELL=/bin/sh")
+                         (string-append "SHELL=" (which "sh"))))
+                      #t))
+                  ;; drop strip phase to make maxima build, see
+                  ;; https://www.ma.utexas.edu/pipermail/maxima/2008/009769.html
+                  (delete 'strip))))
     (inputs
      `(("gmp" ,gmp)
        ("readline" ,readline)))