summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-07-12 18:18:32 -0400
committerLeo Famulari <leo@famulari.name>2016-07-12 18:21:24 -0400
commit1a27944905b0fb843a6460e984238c5a204ed1e3 (patch)
tree66624ebaff5a513b7aa0a199760ecf36baeedd5b
parentbfd77809ecdb96606f268e13f6b5701f760a6b5c (diff)
downloadguix-1a27944905b0fb843a6460e984238c5a204ed1e3.tar.gz
Revert "gnu: python-sphinx: Update to 1.4.4."
This reverts commit efb386ca5c07c5a4571de8561fd5dcd2a4d9cec7.
-rw-r--r--gnu/packages/python.scm27
1 files changed, 8 insertions, 19 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e9020c1f7e..4479dddb2d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2677,33 +2677,22 @@ reStructuredText.")
 (define-public python-sphinx
   (package
     (name "python-sphinx")
-    (version "1.4.4")
+    (version "1.2.3")
     (source
      (origin
        (method url-fetch)
-       (uri (pypi-uri "Sphinx" version))
+       (uri (string-append
+             "https://pypi.python.org/packages/source/S/Sphinx/Sphinx-"
+             version ".tar.gz"))
        (sha256
         (base32
-         "185zklh44fhrwp1dg6251g3w6zmssh5jzvbz8pvmkg9l6wvxdzry"))))
+         "011xizm3jnmf4cvs5i6kgf6c5nn046h79i8j0vd0f27yw9j3p4wl"))))
     (build-system python-build-system)
     (inputs
-     `(
-       ("python-alabaster" ,python-alabaster)
-       ("python-babel" ,python-babel)
-       ("python-docutils" ,python-docutils)
-       ("python-imagesize" ,python-imagesize)
+     `(("python-setuptools" ,python-setuptools)
        ("python-jinja2" ,python-jinja2)
-       ("python-pygments" ,python-pygments)
-       ("python-pytz" ,python-pytz)
-       ("python-setuptools" ,python-setuptools)
-       ("python-six" ,python-six)))
-
-    ;; Several packages that use Sphinx want to use these propagated
-    ;; dependencies when using Sphinx.  Rather than add them to all the Sphinx
-    ;; users, we propagate them from Sphinx.
-    (propagated-inputs
-     `(("python-pytz" ,python-pytz)
-       ("python-snowballstemmer" ,python-snowballstemmer)))
+       ("python-docutils" ,python-docutils)
+       ("python-pygments" ,python-pygments)))
     (home-page "http://sphinx-doc.org/")
     (synopsis "Python documentation generator")
     (description "Sphinx is a tool that makes it easy to create documentation