summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-29 22:12:57 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-29 22:43:48 +0100
commit25d09f609e28337a579fecbcb9b53012009d00c2 (patch)
tree3352f1c826dc172218de83f1be959584135f7dd9
parent4bb74ed5f275e889477da2e0edc01c82b491d985 (diff)
downloadguix-25d09f609e28337a579fecbcb9b53012009d00c2.tar.gz
gnu: slop: Fetch sources from git.
* gnu/packages/xdisorg.scm (slop)[source]: Fetch from git.
-rw-r--r--gnu/packages/xdisorg.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 1b05897173..780fcd4c7c 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -496,14 +496,14 @@ of the screen selected by mouse.")
     (name "slop")
     (version "7.4")
     (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/naelstrof/slop/archive/v"
-                    version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/naelstrof/slop.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1kpdrikgpjb4fpxalb6pjcih5njv1w9cnrjj5612ywdv1q5mjs48"))))
+                "0fgd8a2dqkg64all0f96sca92sdss9r3pzmv5kck46b99z2325z6"))))
     (build-system cmake-build-system)
     (arguments
      '(#:tests? #f)) ; no "check" target