summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-09-27 08:51:00 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-09-27 08:59:02 +0300
commit43438fd13062a29bc6bac71aa12a5077dc013f34 (patch)
treea00b1be39bc0859450757c26de70c444806f1046
parentc776b6ba8e3fc825d60cb292f18dcdf4eb38d95f (diff)
downloadguix-43438fd13062a29bc6bac71aa12a5077dc013f34.tar.gz
gnu: python-graphql-relay: Update to 3.1.0.
* gnu/packages/python-xyz.scm (python-graphql-relay): Update to 3.1.0.
[propagated-inputs]: Remove python-promise and python-six.
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4f5cb10b62..86b1cdc2b1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16449,21 +16449,19 @@ to Python.")
 (define-public python-graphql-relay
   (package
     (name "python-graphql-relay")
-    (version "0.4.5")
+    (version "3.1.0")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "graphql-relay" version))
         (sha256
          (base32
-          "1nv5dxcj59zv31qvl8bd142njmxcmymny2dz3br1l2cpbljbf5i7"))))
+          "1d70vwam9gjhx7fqzsa03x7lc6ivcqki5r9pk8m7rslmb7pagmbh"))))
     (build-system python-build-system)
     (arguments
      '(#:tests? #f)) ; The tests are not distributed
     (propagated-inputs
-     `(("python-graphql-core" ,python-graphql-core)
-       ("python-promise" ,python-promise)
-       ("python-six" ,python-six)))
+     `(("python-graphql-core" ,python-graphql-core)))
     (home-page "https://github.com/graphql-python/graphql-relay-py")
     (synopsis "Relay implementation for Python")
     (description