summary refs log tree commit diff
diff options
context:
space:
mode:
authorAttila Lendvai <attila@lendvai.name>2021-12-01 16:47:07 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-01 17:58:33 +0100
commit508200d66acb5f6d38a53e787f78d7ae388b8083 (patch)
treeff3cf3ceacf7c3c594b61fb18c3ed0235cddc1ea
parent8cc099b4250589c0d23fc6762868f6542433f143 (diff)
downloadguix-508200d66acb5f6d38a53e787f78d7ae388b8083.tar.gz
gnu: python-daemon: Update to 2.3.0.
* gnu/packages/python-xyz.scm (python-daemon): Update to 2.3.0.
[native-inputs]: Add python-coverage and python-twine.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0de304e100..f5ff039d24 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4149,14 +4149,14 @@ logging and tracing of the execution.")
 (define-public python-daemon
   (package
     (name "python-daemon")
-    (version "2.2.3")
+    (version "2.3.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "python-daemon" version))
        (sha256
         (base32
-         "09fcjdjzk9ywmpnrj62iyxqgcygzdafsz41qlrk2dknzbagcmzmg"))))
+         "1bxfn2bq56sd4w0nm9mqy8y0905m7fc8vmhnjxlrf49vcbqr7adx"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -4171,9 +4171,11 @@ logging and tracing of the execution.")
     (propagated-inputs
      `(("python-lockfile" ,python-lockfile)))
     (native-inputs
-     `(("python-unittest2" ,python-unittest2)
+     `(("python-coverage" ,python-coverage)
+       ("python-unittest2" ,python-unittest2)
        ("python-testtools" ,python-testtools)
        ("python-testscenarios" ,python-testscenarios)
+       ("python-twine" ,python-twine)
        ("python-mock" ,python-mock)
        ("python-docutils" ,python-docutils)))
     (home-page "https://pagure.io/python-daemon/")