summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-26 20:46:27 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-26 20:46:27 +0200
commit7335f4617c7ecc0805f46e07c77c2ab97314271c (patch)
treeea88c9be2f13ea89a092bd384f034a0c4af7d1ae
parented1ff94fe23dbe28ce39fa9c7be5bec6c1ae29dc (diff)
downloadguix-7335f4617c7ecc0805f46e07c77c2ab97314271c.tar.gz
gnu: emacs-pretty-mode: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-pretty-mode)[source]: Download using
git-fetch.
-rw-r--r--gnu/packages/emacs-xyz.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7d36c6dcbf..788cbc7b4a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8472,13 +8472,14 @@ been adapted to work with mu4e.")
     (version "2.0.3")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/akatov/pretty-mode/"
-                           "archive/" version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/akatov/pretty-mode/")
+              (commit version)))
+       (file-name (git-file-name name version))
        (sha256
         (base32
-         "1fan7m4vnqs8kpg7r54kx3g7faadkpkf9kzarfv8n57kq8w157pl"))))
+         "013fig9i4fyx16krp2vfv953p3rwdzr38zs6i50af4pqz4vrcfvh"))))
     (build-system emacs-build-system)
     (home-page "https://github.com/akatov/pretty-mode")
     (synopsis "Redisplay parts of the buffer as Unicode symbols")