summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-11-23 22:02:52 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-27 09:48:40 +0100
commit7a146c252835c992e7aa9647d59d2732f78d34d8 (patch)
tree49cfc28e2a2890f8e3699e478bf986315ee57c68
parent36dd594316df1b89137735c07018df17ae6310bf (diff)
downloadguix-7a146c252835c992e7aa9647d59d2732f78d34d8.tar.gz
gnu: Add perl-datetime-calendar-julian.
* gnu/packages/perl.scm (perl-datetime-calendar-julian): New variable.
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index d3df8b20c1..5a42cbb354 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1670,6 +1670,30 @@ combinations.  It represents the Gregorian calendar, extended backwards in
 time before its creation (in 1582).")
     (license artistic2.0)))
 
+(define-public perl-datetime-calendar-julian
+  (package
+    (name "perl-datetime-calendar-julian")
+    (version "0.04")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/P/PI/PIJLL/"
+                           "DateTime-Calendar-Julian-" version ".tar.gz"))
+       (sha256
+        (base32
+         "03h0llkwsiw2d2ci1ah5x9sp8xrvnbgd471i5hnpgl5w32nnhndv"))))
+    (build-system perl-build-system)
+    ;; Only needed for tests
+    (native-inputs
+     `(("perl-datetime" ,perl-datetime)))
+    (home-page "http://search.cpan.org/dist/DateTime-Calendar-Julian")
+    (synopsis "Dates in the Julian calendar")
+    (description "This package is a companion module to @code{DateTime.pm}.
+It implements the Julian calendar.  It supports everything that
+@code{DateTime.pm} supports and more: about one day per century more, to be
+precise.")
+    (license (package-license perl))))
+
 (define-public perl-datetime-set
   (package
     (name "perl-datetime-set")