summary refs log tree commit diff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-05-14 16:23:55 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-05-14 16:53:11 +0200
commit9bb89b640ac37a1fdee927f7c3376eb6f0746cb5 (patch)
treea78c58d0ee11a8850e6cc9181b04b655132fbb28
parent16ad755f94597cc47725a030ef1a65f94d4155c8 (diff)
downloadguix-9bb89b640ac37a1fdee927f7c3376eb6f0746cb5.tar.gz
gnu: gnuradio-osmosdr: Fix Python tools.
* gnu/packages/radio.scm (gnuradio-osmosdr)[native-inputs]: Move python to ...
  [inputs]: ... here. Add python-numpy and python-pyqt.
  [arguments]: Add Python wrapping phase.
-rw-r--r--gnu/packages/radio.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index c0898657a5..f25c097bbc 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -497,7 +497,6 @@ environment.")
        `(("doxygen" ,doxygen)
          ("pkg-config" ,pkg-config)
          ("pybind11" ,pybind11)
-         ("python" ,python)
          ("python-mako" ,python-mako)
          ("python-six" ,python-six)))
       (inputs
@@ -509,8 +508,21 @@ environment.")
          ("hackrf" ,hackrf)
          ("libsndfile" ,libsndfile)
          ("log4cpp" ,log4cpp)
+         ("python" ,python)
+         ("python-numpy" ,python-numpy)
+         ("python-pyqt" ,python-pyqt)
          ("rtl-sdr" ,rtl-sdr)
          ("volk" ,volk)))
+      (arguments
+       `(#:modules ((guix build cmake-build-system)
+                    ((guix build python-build-system) #:prefix python:)
+                    (guix build utils))
+         #:imported-modules (,@%cmake-build-system-modules
+                             (guix build python-build-system))
+         #:phases
+         (modify-phases %standard-phases
+           (add-after 'install 'wrap-python
+             (assoc-ref python:%standard-phases 'wrap)))))
       (synopsis "GNU Radio block for interfacing with various radio hardware")
       (description "This is a block for GNU Radio allowing to use a common API
 to access different radio hardware.")