summary refs log tree commit diff
diff options
context:
space:
mode:
authorJean-Baptiste Note <jean-baptiste.note@m4x.org>2020-05-08 20:26:02 +0000
committerMathieu Othacehe <othacehe@gnu.org>2020-05-10 09:51:36 +0200
commitc0792d77ddc855e657ac8e98f840856a4e40c224 (patch)
treeba157721ffe3af7522282f0f6c4197df1a93087c
parent8f929fdf0b82b591878d277a57e54288026180e9 (diff)
downloadguix-c0792d77ddc855e657ac8e98f840856a4e40c224.tar.gz
gnu: Add cachefilesd.
* gnu/packages/linux.scm (cachefilesd): New public variable.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/linux.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e9fdf94ec6..ecd9917dda 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6954,3 +6954,40 @@ utilities.  Using @code{kexec}, it is possible to boot directly into a new
 kernel from the context of an already-running kernel, bypassing the normal
 system boot process.")
     (license license:gpl2)))
+
+(define-public cachefilesd
+  (package
+    (name "cachefilesd")
+    (version "0.10.10")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://git.kernel.org/pub/scm/linux/kernel/git/dhowells"
+                    "/cachefilesd.git/snapshot/cachefilesd-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "0g40ljjnn3wzh9gp6il21c95f977298qrrkrxfnwfl3k3asfmnbi"))))
+    (build-system gnu-build-system)
+    (outputs '("out"))
+    (arguments
+     `(#:tests? #f ; there are no tests
+       #:make-flags
+       (let ((prefix-dir (lambda (var dir)
+                           (string-append var "=" %output "/" dir)))
+             (target ,(%current-target-system)))
+         (list (string-append "CC="
+                              (if target
+                                  (string-append target "-gcc")
+                                  "gcc"))
+               (prefix-dir "SBINDIR" "sbin/")
+               (prefix-dir "ETCDIR" "etc/")
+               (prefix-dir "MANDIR" "share/man/")))
+       #:phases (modify-phases %standard-phases (delete 'configure))))
+    (home-page "https://people.redhat.com/~dhowells/cachefs/")
+    (synopsis "CacheFiles userspace management daemon")
+    (description "@code{cachefilesd} is a userspace daemon that manages the
+cache data store that is used by network file systems such as @code{AFS} and
+@code{NFS} to cache data locally on disk.  The content of the cache is
+persistent over reboots.")
+    (license license:gpl2+)))