summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-01 00:45:04 +0100
committerMarius Bakke <marius@gnu.org>2021-12-05 14:02:08 +0100
commitde5a8b26f276035d2f3b949ee4f147a694c42c23 (patch)
tree13842de4d41e9e0f020411ec56062a04adbb04f7
parentacbc01940b57c8edcefda68785c676aa98c851ca (diff)
downloadguix-de5a8b26f276035d2f3b949ee4f147a694c42c23.tar.gz
gnu: python-django-haystack: Disable sanity check.
* gnu/packages/django.scm (python-django-haystack)[arguments]: Delete one
phase.  While at it, remove trailing #t's.
-rw-r--r--gnu/packages/django.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index c11d3cf2b5..5c1c314fe2 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -405,14 +405,14 @@ useful tools for testing Django applications and projects.")
          (add-after 'unpack 'loosen-verion-restrictions
            (lambda _
              (substitute* "setup.py"
-               (("geopy.*") "geopy',\n"))
-             #t))
+               (("geopy.*") "geopy',\n"))))
          (add-before 'check 'set-gdal-lib-path
            (lambda* (#:key inputs #:allow-other-keys)
              (setenv "GDAL_LIBRARY_PATH"
                      (string-append (assoc-ref inputs "gdal")
-                                    "/lib"))
-             #t)))
+                                    "/lib"))))
+         ;; Importing this module requires setting up a Django project.
+         (delete 'sanity-check))
        #:tests? #f)) ; OSError: libgdal.so.27: cannot open shared object file
     (propagated-inputs
      `(("python-django" ,python-django)))