summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-25 11:21:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-25 11:22:02 +0200
commitf66759e0b2410aaa2ad8e74ef5c0aaf728abb6ba (patch)
tree0b768d7f7bfea7532d6eeaf535d83e7fe4b9d792
parentae3e6ba506f57a4353f491242a3f5e4d419f9aa9 (diff)
downloadguix-f66759e0b2410aaa2ad8e74ef5c0aaf728abb6ba.tar.gz
gnu: Add ivar.
* gnu/packages/bioinformatics.scm (ivar): New variable.
-rw-r--r--gnu/packages/bioinformatics.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 426926a37c..e663ff2591 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14272,6 +14272,32 @@ sequencing (e.g. mapping or base/indel alignment uncertainty), which are
 usually ignored by other methods or only used for filtering.")
     (license license:expat)))
 
+(define-public ivar
+  (package
+    (name "ivar")
+    (version "1.3.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/andersen-lab/ivar")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "044xa0hm3b8fga64csrdx05ih8w7kwmvcdrdrhkg8j11ml4bi4xv"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("htslib" ,htslib)
+       ("zlib" ,zlib)))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)))
+    (home-page "https://andersen-lab.github.io/ivar/html/")
+    (synopsis "Tools for amplicon-based sequencing")
+    (description "iVar is a computational package that contains functions
+broadly useful for viral amplicon-based sequencing. ")
+    (license license:gpl3+)))
+
 (define-public python-pyliftover
   (package
     (name "python-pyliftover")