summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-08-23 11:45:59 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-08-23 11:45:59 +0200
commit090663a7a5dcc3b9a2af1e7c70e1842f983a24f7 (patch)
treef0c656444719d437e240b2494c2fa6e4f9e54391
parentf6bcde85a6d227ddf492dd89f7e79ef2835cb228 (diff)
downloadguix-090663a7a5dcc3b9a2af1e7c70e1842f983a24f7.tar.gz
gnu: Add r-bladderbatch.
* gnu/packages/bioconductor.scm (r-bladderbatch): New variable.
-rw-r--r--gnu/packages/bioconductor.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 55b0024171..8842b0feb5 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1221,6 +1221,27 @@ demonstration purposes in the @code{AneuFinder} package.")
 from Illumina 450k methylation arrays.")
     (license license:artistic2.0)))
 
+(define-public r-bladderbatch
+  (package
+    (name "r-bladderbatch")
+    (version "1.34.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "bladderbatch" version
+                                     'experiment))
+              (sha256
+               (base32
+                "1dpbaqsqizyi99r0imf5m4lndhhrkyiaqii9bi8rp18fjbjdd72k"))))
+    (properties `((upstream-name . "bladderbatch")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-biobase))
+    (home-page "https://bioconductor.org/packages/bladderbatch")
+    (synopsis "Bladder gene expression data illustrating batch effects")
+    (description
+     "This package contains microarray gene expression data on 57 bladder samples from
+5 batches.  The data are used as an illustrative example for the sva package.")
+    (license license:artistic2.0)))
+
 (define-public r-biscuiteerdata
   (package
     (name "r-biscuiteerdata")