summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-05-06 14:12:41 +0200
committerLudovic Courtès <ludo@gnu.org>2014-05-06 14:12:41 +0200
commit0997771ac19d7aa5c51ba25f87f9e08de324edae (patch)
treece5becb315c28c1c840b5e8c17b2f1f1a5bc22f2
parentfd42e6b80343f0a250396150d00c0d3401ac60a9 (diff)
downloadguix-0997771ac19d7aa5c51ba25f87f9e08de324edae.tar.gz
gnu: e2fsprogs: Use 'static-package' for the statically-linked variant.
* gnu/packages/linux.scm (e2fsprogs/static): Remove.
  (e2fsck/static): Use (static-package e2fsprogs) instead.
-rw-r--r--gnu/packages/linux.scm17
1 files changed, 4 insertions, 13 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3325679258..f04fd5ce6b 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -467,19 +467,10 @@ slabtop, and skill.")
                    lgpl2.0                        ; libext2fs
                    x11))))                        ; libuuid
 
-(define-public e2fsprogs/static
-  (package (inherit e2fsprogs)
-    (name "e2fsprogs-static")
-    (arguments
-     `(#:configure-flags '("LDFLAGS=-static")
-       ,@(package-arguments e2fsprogs)))
-    (synopsis
-     "Statically-linked version of the ext2/ext3/ext4 file system tools")))
-
 (define-public e2fsck/static
   (package
     (name "e2fsck-static")
-    (version (package-version e2fsprogs/static))
+    (version (package-version e2fsprogs))
     (build-system trivial-build-system)
     (source #f)
     (arguments
@@ -501,13 +492,13 @@ slabtop, and skill.")
                          (remove-store-references file)
                          (chmod file #o555))
                        (scandir source (cut string-prefix? "fsck." <>))))))))
-    (inputs `(("e2fsprogs" ,e2fsprogs/static)))
+    (inputs `(("e2fsprogs" ,(static-package e2fsprogs))))
     (synopsis "Statically-linked fsck.* commands from e2fsprogs")
     (description
      "This package provides statically-linked command of fsck.ext[234] taken
 from the e2fsprogs package.  It is meant to be used in initrds.")
-    (home-page (package-home-page e2fsprogs/static))
-    (license (package-license e2fsprogs/static))))
+    (home-page (package-home-page e2fsprogs))
+    (license (package-license e2fsprogs))))
 
 (define-public strace
   (package