summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-26 20:43:04 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-26 20:43:04 +0200
commit0dcb8e83f4c96cffa790b46768496988b390937a (patch)
tree795b25e5f0ad2483b84abb925bb84124a1c36299
parentd1de1ab21a9477f72632d3b217d50d889ca136bf (diff)
downloadguix-0dcb8e83f4c96cffa790b46768496988b390937a.tar.gz
gnu: emacs-cyberpunk-theme: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-cyberpunk-theme)[source]: Download
using git-fetch.
-rw-r--r--gnu/packages/emacs-xyz.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7cebb8192d..415814baa2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8060,13 +8060,14 @@ Flx has support for ido (interactively do things) through flx-ido.")
     (version "1.19")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/n3mo/cyberpunk-theme.el/"
-                           "archive/" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/n3mo/cyberpunk-theme.el/")
+              (commit version)))
        (sha256
         (base32
-         "05l5fxw1mn5py6mfhxrzyqjq0d8m5m1akfi46vrgh13r414jffvv"))
-       (file-name (string-append name "-" version ".tar.gz"))))
+         "1npwrw3pgdmvqhihcqcfi2yrs178iiip5fcj8zhpp6cr9yqsvvgi"))
+       (file-name (git-file-name name version))))
     (build-system emacs-build-system)
     (home-page "https://github.com/n3mo/cyberpunk-theme.el")
     (synopsis "Cyberpunk theme for emacs built-in color theme support")