summary refs log tree commit diff
diff options
context:
space:
mode:
authorCharles <charles.b.jackson@protonmail.com>2021-09-18 01:13:45 -0500
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-19 09:24:22 +0200
commit110fdaad4e9e50e694c1d03a805653482aa7e4bf (patch)
tree226962f5d0ff5d68a134c50272e921c5fd49a770
parent8594fd6bff027cbe19337602924f8963a5765b54 (diff)
downloadguix-110fdaad4e9e50e694c1d03a805653482aa7e4bf.tar.gz
gnu: Add cl-schemeish.
* gnu/packages/lisp-xyz.scm (sbcl-schemeish, ecl-schemeish, cl-schemeish): New
  variables.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 06ce3c699e..19948f36b3 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5524,6 +5524,39 @@ the CFFI approach used by burgled-batteries, but has the same goal.")
 (define-public ecl-py4cl
   (sbcl-package->ecl-package sbcl-py4cl))
 
+(define-public sbcl-schemeish
+  (let ((commit "dff57bafae5d0cffa104c8fdc4146502f32d7f85")
+        (revision "1"))
+    (package
+      (name "sbcl-schemeish")
+      (version (git-version "0.0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/chebert/schemeish")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0q9b07spmhg1b576cnnacvkf7zr3mab2rdydfylbn92y9mms9vyj"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       `(("trivial-arguments" ,sbcl-trivial-arguments)))
+      (synopsis "Scheme style syntax/macros/functions for Common Lisp")
+      (description
+       "Schemeish implements several useful Scheme constructs for Common Lisp.
+These include named-let, define, scheme argument lists, and a shortcut to
+FUNCALL with [] instead of ().")
+      (home-page "https://github.com/chebert/schemeish")
+      ;; MIT License
+      (license license:expat))))
+
+(define-public cl-schemeish
+  (sbcl-package->cl-source-package sbcl-schemeish))
+
+(define-public ecl-schemeish
+  (sbcl-package->ecl-package sbcl-schemeish))
+
 (define-public sbcl-parse-declarations
   (let ((commit "549aebbfb9403a7fe948654126b9c814f443f4f2")
         (revision "1"))