summary refs log tree commit diff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-08 23:32:00 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:18 +0300
commit1a53f5b998db72ebae6ee6dd16b837dee4586d55 (patch)
tree1d78ae0efde91a9b72f929e4d2dd8f0016deeb35
parent1d47f7526628c0fbfa6079ebcb3cd8c82c5304ea (diff)
downloadguix-1a53f5b998db72ebae6ee6dd16b837dee4586d55.tar.gz
gnu: Add go-github-com-alecthomas-colour.
* gnu/packages/golang.scm (go-github-com-alecthomas-colour): New variable.
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ee501e8d0b..d7be3f5f7f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4517,3 +4517,31 @@ matching and globbing with support for \"doublestar\" patterns.")
     (synopsis "Full featured regular expressions for Go")
     (description "Regexp2 is a feature-rich RegExp engine for Go.")
     (license license:expat)))
+
+(define-public go-github-com-alecthomas-colour
+  (package
+    (name "go-github-com-alecthomas-colour")
+    (version "0.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/alecthomas/colour")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "10zbm12j40ppia4b5ql2blmsps5jhh5d7ffphxx843qk7wlbqnjb"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/alecthomas/colour"))
+    (native-inputs
+     `(("go-github-com-mattn-go-isatty" ,go-github-com-mattn-go-isatty)))
+    (home-page "https://github.com/alecthomas/colour/")
+    (synopsis "Colour terminal text for Go")
+    (description "Package colour provides Quake-style colour formatting for
+Unix terminals.
+
+The package level functions can be used to write to stdout (or strings or
+other files).  If stdout is not a terminal, colour formatting will be
+stripped.")
+    (license license:expat)))