summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-02-28 16:39:48 +0100
committerLudovic Courtès <ludo@gnu.org>2016-02-28 16:41:53 +0100
commit1a59b6d01423060f6364596376db96984b3dccf1 (patch)
tree0e6a442147738a9d6263dc53631c4474300b90f1
parentdbb7a081756adc3262a18f1325b26adedce708bf (diff)
downloadguix-1a59b6d01423060f6364596376db96984b3dccf1.tar.gz
gnu: git: Install symlinks instead of hard links.
This reduces nar size by a factor of 10.
Fixes <http://bugs.gnu.org/21949>.

* gnu/packages/version-control.scm (git)[arguments]: Pass
NO_INSTALL_HARDLINKS as #:make-flags.
-rw-r--r--gnu/packages/version-control.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 0712f9f392..2215d4991d 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
-;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
@@ -149,7 +149,12 @@ as well as the classic centralized workflow.")
               "svn"                               ; git-svn
               "gui"))                             ; gitk, git gui
    (arguments
-    `(#:make-flags `("V=1") ; more verbose compilation
+    `(#:make-flags `("V=1"                        ;more verbose compilation
+
+                     ;; By default 'make install' creates hard links for
+                     ;; things in 'libexec/git-core', which leads to huge
+                     ;; nars; see <http://bugs.gnu.org/21949>.
+                     "NO_INSTALL_HARDLINKS=indeed")
       #:test-target "test"
       #:tests? #f ; FIXME: Many tests are failing