summary refs log tree commit diff
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-03-16 16:32:25 +0100
committerChristopher Baines <mail@cbaines.net>2020-12-08 20:18:11 +0000
commit20e5658c0471c76cc297cfd30ad49f0585310e27 (patch)
tree3e430aa32b6d67f38a6ebbbc880d9b0072bed505
parent2d1a621b8dc39f7903b47b84c1f8de253ae4fc43 (diff)
downloadguix-20e5658c0471c76cc297cfd30ad49f0585310e27.tar.gz
gnu: ocaml-menhir: Update to 20200211.
* gnu/packages/ocaml.scm (ocaml-menhir): Update to 20200211.
[build-system]: Switch from gnu to dune.
[arguments]: Remove phases and make-flags.
[native-inputs]: Remove field.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/ocaml.scm16
1 files changed, 4 insertions, 12 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 369e819573..2bfda7307e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -739,8 +739,7 @@ Emacs.")
 (define-public ocaml-menhir
   (package
     (name "ocaml-menhir")
-    ;; More recent versions can be built after we have dune >= 2.0
-    (version "20190626")
+    (version "20200211")
     (source
      (origin
        (method git-fetch)
@@ -749,19 +748,12 @@ Emacs.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0v8av4pw6rykzb7wx54xhbsx0jhh8xyb4x0k4yrxi0w5ylkck6mb"))))
-    (build-system ocaml-build-system)
+        (base32 "019izf51kdc7pzkw68zg8a2alc8lxw1gwdp7in970mr90n16b5zj"))))
+    (build-system dune-build-system)
     (inputs
      `(("ocaml" ,ocaml)))
-    (native-inputs
-     `(("ocamlbuild" ,ocamlbuild)))
     (arguments
-     `(#:make-flags `("USE_OCAMLFIND=true"
-                      ,(string-append "PREFIX=" (assoc-ref %outputs "out")))
-       #:tests? #f ; No check target
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure))))
+     `(#:tests? #f)) ; No check target
     (home-page "http://gallium.inria.fr/~fpottier/menhir/")
     (synopsis "Parser generator")
     (description "Menhir is a parser generator.  It turns high-level grammar