summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-10-27 23:45:29 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-27 23:46:14 +0100
commit271b3c9d16f8880f4a27b52a615cdec611322fae (patch)
treeafd36786a4b15e7184268a414e6289641fc4b3a6
parent6c5401fca8d5b491367f700082b79fb8090ec294 (diff)
downloadguix-271b3c9d16f8880f4a27b52a615cdec611322fae.tar.gz
gnu: fetchmail: Update to 6.4.1.
* gnu/packages/mail.scm (fetchmail): Update to 6.4.1.
[source]: Parameterize URI.
[arguments]: Add ‘create-test-environment’ phase.
-rw-r--r--gnu/packages/mail.scm29
1 files changed, 19 insertions, 10 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 2c6192ca01..dc7f6c591e 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -320,20 +320,29 @@ to run without any changes.")
 (define-public fetchmail
   (package
     (name "fetchmail")
-    (version "6.3.26")
-    (source (origin
-             (method url-fetch)
-             (uri (string-append "mirror://sourceforge/fetchmail/branch_6.3/fetchmail-"
-                                 version ".tar.xz"))
-             (sha256
-              (base32
-               "0l78ayvi9dm8hd190gl139cs2xqsrf7r9ncilslw20mgvd6cbd3r"))))
+    (version "6.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/fetchmail/branch_"
+                           (version-major+minor version) "/"
+                           "fetchmail-" version ".tar.xz"))
+       (sha256
+        (base32 "1859wvfc9fq72mwp4njdiy0x89hnddlfr3nix71qqglcs0fz2crz"))))
     (build-system gnu-build-system)
     (inputs
      `(("openssl" ,openssl)))
     (arguments
-     `(#:configure-flags (list (string-append "--with-ssl="
-                                              (assoc-ref %build-inputs "openssl")))))
+     `(#:configure-flags
+       (list (string-append "--with-ssl="
+                            (assoc-ref %build-inputs "openssl")))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'create-test-environment
+           (lambda _
+             ;; Fix ‘Cannot find absolute path for user's home directory’.
+             (setenv "HOME" "/tmp")
+             #t)))))
     (home-page "http://www.fetchmail.info/")
     (synopsis "Remote-mail retrieval and forwarding utility")
     (description