summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-02-10 23:16:46 +0100
committerLudovic Courtès <ludo@gnu.org>2017-02-10 23:39:46 +0100
commit340f9b9fa0bdbe65c570b57504d39ff30fc1dd4a (patch)
treef5919487b8a26291c6fa7db6793a079be1d757db
parent533bc51469bf291ac935a463bcbd8fdb93b5976c (diff)
downloadguix-340f9b9fa0bdbe65c570b57504d39ff30fc1dd4a.tar.gz
gnu: librstp: Allow tests to run.
Fixes <http://bugs.gnu.org/25669>.
Reported by Maxim Cournoyer <maxim.cournoyer@gmail.com>.

Before that, the sender process in test/rtpw_test.sh would try to read
words from the parent directory, and thus it would return almost
immediately (as if it had read an empty file, no error).

* gnu/packages/telephony.scm (libsrtp)[inputs]: Add PSMISC.
[arguments]: In 'patch-dictionary-location' phase, set the name of the
'FAQ' file rather than the name of its parent directory.
-rw-r--r--gnu/packages/telephony.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index c393caace8..b0cefe4056 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -215,7 +215,8 @@ internet.")
               (base32
                "1w2g623qkd7gdyydglx2hr4s2y237lg0nszjmy7z8d2iq8hvb9sn"))))
     (native-inputs
-     `(("procps" ,procps)))
+     `(("psmisc" ,psmisc)                        ;some tests require 'killall'
+       ("procps" ,procps)))
     (build-system gnu-build-system)
     (arguments
      '(#:test-target "runtest"
@@ -234,8 +235,8 @@ internet.")
              (substitute* "test/rtpw.c"
                (("/usr/share/dict/words")
                 (string-append (assoc-ref %build-inputs "procps")
-                               "/share/doc/procps-ng"))
-                (("words.txt") "FAQ"))
+                               "/share/doc/procps-ng/FAQ"))
+               (("words.txt") "FAQ"))
              #t)))))
     (synopsis "Secure RTP (SRTP) Reference Implementation")
     (description "This package provides an implementation of the Secure