summary refs log tree commit diff
diff options
context:
space:
mode:
authorhumanitiesNerd <catonano@gmail.com>2017-04-05 12:42:05 +0200
committerAlex Kost <alezost@gmail.com>2017-04-07 20:22:29 +0300
commit350cfccb069ff6b8fd9625268612ce09be5f66c9 (patch)
treeb969773f8f0f610d8f84f5edff8acca77c968b6c
parentb0dd3436ed4387ed768b4e9da9bcedb6d8c08d50 (diff)
downloadguix-350cfccb069ff6b8fd9625268612ce09be5f66c9.tar.gz
gnu: Add emacs-adaptive-wrap.
Suggested-by Ivan Vilata i Balaguer <ivan@selidor.net>.
Fixes <https://bugs.gnu.org/26367>.

* gnu/packages/emacs.scm (emacs-adaptive-wrap): New variable.

Signed-off-by: Alex Kost <alezost@gmail.com>
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 15ab6b4866..f6f8fcfba4 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4057,3 +4057,26 @@ jQuery and Bootstrap resources included via osscdn.")
     (description
      "This Emacs package highlights the s-exp at the current position.")
     (license license:gpl3+)))
+
+(define-public emacs-adaptive-wrap
+  (package
+    (name "emacs-adaptive-wrap")
+    (version "0.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://elpa.gnu.org/packages/adaptive-wrap-"
+                    version ".el"))
+              (sha256
+               (base32
+                "0frgmp8vrrml4iykm60j4d6cl9rbcivy9yh24q6kd10bcyx59ypy"))))
+    (build-system emacs-build-system)
+    (home-page "http://elpa.gnu.org/packages/adaptive-wrap.html")
+    (synopsis "Smart line-wrapping with wrap-prefix")
+    (description
+     "This Emacs package provides the @code{adaptive-wrap-prefix-mode}
+minor mode which sets the wrap-prefix property on the fly so that
+single-long-line paragraphs get word-wrapped in a way similar to what
+you'd get with @kbd{M-q} using @code{adaptive-fill-mode}, but without
+actually changing the buffer's text.")
+    (license license:gpl3+)))