summary refs log tree commit diff
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2014-02-20 15:27:25 +0000
committerLudovic Courtès <ludo@gnu.org>2014-02-20 23:18:08 +0100
commit396b3c8b55344e3833d57b5b179830f5719c1746 (patch)
tree2782395e950a13d62f6270919a270443abe9e782
parentc6d37be9511f6f10b766541977311341a9115ee9 (diff)
downloadguix-396b3c8b55344e3833d57b5b179830f5719c1746.tar.gz
gnu: hurd: Add MiG.
* gnu/packages/hurd.scm (mig): New variable.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/hurd.scm33
1 files changed, 32 insertions, 1 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index f915eda9cb..3edccbdd1c 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -20,7 +20,9 @@
   #:use-module (guix licenses)
   #:use-module (guix download)
   #:use-module (guix packages)
-  #:use-module (guix build-system gnu))
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages flex)
+  #:use-module (gnu packages bison))
 
 (define-public gnumach-headers
   (package
@@ -55,3 +57,32 @@
     (description
      "Headers of the GNU Mach kernel.")
     (license gpl2+)))
+
+(define-public mig
+  (package
+    (name "mig")
+    (version "1.4")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://gnu/mig/mig-"
+                          version ".tar.gz"))
+      (sha256
+       (base32
+        "1jgzggnbp22sa8z5dilm43zy12vlf1pjxfb3kh13xrfhcay0l97b"))))
+    (build-system gnu-build-system)
+    (inputs `(("gnumach-headers" ,gnumach-headers)))
+    (native-inputs
+     `(("flex" ,flex)
+       ("bison" ,bison)))
+    (arguments `(#:tests? #f))
+    (home-page "http://www.gnu.org/software/hurd/microkernel/mach/mig/gnu_mig.html")
+    (synopsis "Mach 3.0 interface generator for the Hurd")
+    (description
+     "GNU MIG is the GNU distribution of the Mach 3.0 interface generator
+MIG, as maintained by the GNU Hurd developers for the GNU project.
+You need this tool to compile the GNU Mach and GNU Hurd distributions,
+and to compile the GNU C library for the Hurd. Also,you will need it
+for other software in the GNU system that uses Mach-based inter-process
+communication.")
+    (license gpl2+)))