summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-20 13:56:42 +0100
committerMarius Bakke <marius@gnu.org>2022-11-20 15:15:33 +0100
commit3a91ee3b88867e05099a3dfb20bddc48d3330c3e (patch)
tree5aa8a3d5a2ecacaad3fc90461c822172fc1daa43
parent7343bb8325c3ca9f252cdcafa06805ca20e97d83 (diff)
downloadguix-3a91ee3b88867e05099a3dfb20bddc48d3330c3e.tar.gz
gnu: protobuf@2: Fix build.
* gnu/packages/protobuf.scm (protobuf-2)[build-system]: Set to GNU-BUILD-SYSTEM.
[arguments]: Clear.
[outputs]: Remove "static".
-rw-r--r--gnu/packages/protobuf.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index eda1b5ec51..a052a38853 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -212,10 +212,9 @@ internal RPC protocols and file formats.")
               (sha256
                (base32
                 "040rcs9fpv4bslhiy43v7dcrzakz4vwwpyqg4jp8bn24sl95ci7f"))))
-    (arguments (substitute-keyword-arguments (package-arguments protobuf)
-                 ((#:phases phases)
-                  #~(modify-phases #$phases
-                      (delete 'disable-broken-tests)))))))
+    (build-system gnu-build-system)
+    (arguments '())
+    (outputs '("out"))))
 
 (define-public protobuf-c
   (package