summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-11-08 21:36:58 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-11-08 21:44:53 +0200
commit3ca1c0666aef3e3eb838bbcf74f5976ae3913292 (patch)
tree08b9973759cecbe38c0033aa5d2990017eff0e4f
parent458a78b927c48c8915a8e76f77373775bd7abe00 (diff)
downloadguix-3ca1c0666aef3e3eb838bbcf74f5976ae3913292.tar.gz
gnu: Add linux-libre-mips64el-fuloong2e.
* gnu/packages/linux.scm (linux-libre-mips64el-fuloong2e): New variable.
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index cce1f70ffd..5e47a6bfb9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1008,6 +1008,17 @@ It has been modified to remove all non-free binary blobs.")
                      '("riscv64-linux")
                      #:extra-version "riscv64-generic"))
 
+(define-public linux-libre-mips64el-fuloong2e
+  (make-linux-libre* linux-libre-version
+                     linux-libre-source
+                     '("mips64el-linux")
+                     #:defconfig "fuloong2e_defconfig"
+                     #:extra-version "mips64el-fuloong2e"
+                     #:extra-options
+                     (append
+                      `(("CONFIG_OVERLAY_FS" . m))
+                      %default-extra-linux-options)))
+
 (define-public linux-libre-with-bpf
   (let ((base-linux-libre
          (make-linux-libre*