summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2020-10-15 12:20:41 +0200
committerChristopher Baines <mail@cbaines.net>2020-10-15 20:49:12 +0100
commit3e072a59be55107bdcde4d1eabe2c857a254ebcc (patch)
tree0fd385994f66e464f843ad79d538499161763009
parenta19983fb4d9e80e301a7b774b4637537b1506e3c (diff)
downloadguix-3e072a59be55107bdcde4d1eabe2c857a254ebcc.tar.gz
gnu: Add tsukundere.
* gnu/packages/game-development.scm (tsukundere): New variable.

Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/game-development.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 061dc13f69..96ed2f9da4 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -485,6 +485,35 @@ clone.")
     ;; under BSD-2.
     (license license:gpl2+)))
 
+(define-public tsukundere
+  (package
+    (name "tsukundere")
+    (version "0.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.com/leoprikler/tsukundere")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0qmqch8hh7vsa8qaz853vwbkz0krb106955dnz8dsl7skbm5jpn6"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("autoconf" ,autoconf-wrapper)
+       ("automake" ,automake)
+       ("guile" ,guile-3.0)
+       ("pkg-config" ,pkg-config)))
+    (propagated-inputs
+     `(("guile-sdl2" ,guile3.0-sdl2)))
+    (home-page "https://gitlab.com/leoprikler/tsukundere")
+    (synopsis "Visual novel engine")
+    (description "Tsukundere is a game engine geared heavily towards the
+development of visual novels, written on top of Guile-SDL2.  It is still
+experimental and at the time of writing contains little more than the Guile
+modules, that make up its runtime.")
+    (license license:lgpl3+)))
+
 (define-public sfml
   (package
     (name "sfml")