summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-09 03:47:32 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-10 00:32:35 +0100
commit4a98f416d6de6d3922e92e3f06305da7207e099b (patch)
treee58d81a225bdfc007194d5cf8e0794873356295f
parent0148fe643947da6b31dab7ceb9c5be7f797e6fd0 (diff)
downloadguix-4a98f416d6de6d3922e92e3f06305da7207e099b.tar.gz
gnu: stunnel: Update to 5.61.
* gnu/packages/web.scm (stunnel): Update to 5.61.
[native-inputs]: Add python.
[arguments]: Remove obsolete 'patch-tests phase.
-rw-r--r--gnu/packages/web.scm14
1 files changed, 4 insertions, 10 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b49c4d96c3..48582b5491 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5793,20 +5793,21 @@ tools like SSH (Secure Shell) to reach the outside world.")
 (define-public stunnel
   (package
   (name "stunnel")
-  (version "5.60")
+  (version "5.61")
   (source
     (origin
       (method url-fetch)
       (uri (string-append "https://www.stunnel.org/downloads/stunnel-"
                           version ".tar.gz"))
       (sha256
-       (base32 "0zbqiydyz9dvfg3axh18a42v6j3xvnwjbd03kgm1z1i12mdpcpf4"))))
+       (base32 "0yjx07r5wc987s4z0wm37381fa3az2s4mrhyjxypx3rd92k0rsli"))))
   (build-system gnu-build-system)
   (native-inputs
    ;; For tests.
    `(("iproute" ,iproute)
      ("netcat" ,netcat)
-     ("procps" ,procps)))
+     ("procps" ,procps)
+     ("python" ,python)))
   (inputs (list openssl))
   (arguments
    `(#:configure-flags
@@ -5821,13 +5822,6 @@ tools like SSH (Secure Shell) to reach the outside world.")
                               "tools/Makefile.in")
              (("/doc/stunnel")
               (string-append "/doc/" ,name "-" ,version)))))
-       (add-before 'check 'patch-tests
-         (lambda _
-           (substitute* "tests/make_test"
-             (("/bin/sh ")
-              (string-append (which "sh") " ")))
-           ;; This test requires networking.
-           (delete-file "tests/recipes/055_socket_closed")))
        (add-after 'install 'prune-documentation
          (lambda* (#:key outputs #:allow-other-keys)
            (let* ((out (assoc-ref outputs "out"))