summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-06 07:06:46 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-07 23:57:38 +0200
commit5f82a9d5cc0e71797cdea6d4e80a7c9148b8bb92 (patch)
tree3eeeaed3f28a680811db6cab6d11fb5e469459f5
parentedf075987c6d6f9e92e20a89f4c9e41bfa0802d6 (diff)
downloadguix-5f82a9d5cc0e71797cdea6d4e80a7c9148b8bb92.tar.gz
gnu: seabios: Return #t from all phases.
* gnu/packages/firmware.scm (seabios)[arguments]: Return #t from
the ‘install’ phase.
-rw-r--r--gnu/packages/firmware.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 7aaa9f36fd..b00ecd15ae 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -209,7 +209,8 @@ by the b43-open driver of Linux-libre.")
              (let* ((out (assoc-ref outputs "out"))
                     (fmw (string-append out "/share/firmware")))
                (mkdir-p fmw)
-               (copy-file "out/bios.bin" (string-append fmw "/bios.bin"))))))))
+               (copy-file "out/bios.bin" (string-append fmw "/bios.bin"))
+               #t))))))
     (home-page "https://www.seabios.org/SeaBIOS")
     (synopsis "x86 BIOS implementation")
     (description "SeaBIOS is an implementation of a 16bit x86 BIOS.  SeaBIOS