summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-11-22 20:41:48 +0100
committerMarius Bakke <mbakke@fastmail.com>2016-11-22 20:44:48 +0100
commit6317d36f3beb246f9d20e2760d4c5f0d20ee196f (patch)
treedfdd9b8f6d903106101893c2fd8ddd91c55fee90
parentbe72eb98fa5767b3d28ab431656d8cac048bac10 (diff)
downloadguix-6317d36f3beb246f9d20e2760d4c5f0d20ee196f.tar.gz
gnu: notmuch: Skip tests that fail with gnupg-2.1.16.
* gnu/packages/mail.scm (notmuch)[arguments]: Add environment variable
to skip tests that broke after gnupg-2.1.16.
-rw-r--r--gnu/packages/mail.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index a365e37f9b..05ab9db07f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -568,6 +568,11 @@ invoking @command{notifymuch} from the post-new hook.")
                       ;; Patch various inline shell invocations.
                       (substitute* (find-files "test" "\\.sh$")
                         (("/bin/sh") (which "sh")))
+                      ;; XXX: Some signature verification tests fail with
+                      ;; gnupg-2.1.16, so we skip them. See this thread:
+                      ;; https://notmuchmail.org/pipermail/notmuch/2016/023688.html
+                      (setenv "NOTMUCH_SKIP_TESTS"
+                              "T350-crypto.2 T350-crypto.3 T350-crypto.4 T350-crypto.15")
                       #t)))))
     (native-inputs
      `(("bash-completion" ,bash-completion)