summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-10-28 13:12:49 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-10-28 15:00:21 +0200
commit65ad002ff10962f83bddf5070c22812f07b6437b (patch)
treef79cfa20e1d2e875fea933487c86f2dba32f5655
parent75b24abf0970cc114cc8a2251c90b54649585575 (diff)
downloadguix-65ad002ff10962f83bddf5070c22812f07b6437b.tar.gz
gnu: ghc-4: Embed absolute file name of GCC in GHC.
* gnu/packages/haskell.scm (ghc-4)[arguments]: Pass "--with-gcc" option to
configure script.
-rw-r--r--gnu/packages/haskell.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 3eaf956d73..0caf741715 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -311,6 +311,9 @@ GhcWithHscBuiltViaC=YES
 ")))
               (invoke "./configure"
                       "--enable-hc-boot" ; boot from C "source" files
+                      ;; Embed the absolute file name of GCC 2.95 in the GHC
+                      ;; driver script.
+                      (string-append "--with-gcc=" (which "gcc"))
                       (string-append "--prefix=" #$output)
                       (string-append "--build=" build)
                       (string-append "--host=" build))))