summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-02-22 10:09:03 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-22 10:24:00 +0100
commit6983b8a8264044c46fbd5c90a11152e2d2303e6b (patch)
tree8723206e182b2a4edb4ef212396fd7f5ada8cbe0
parentc762d09e89746025bc38299a933e7e6aa611b8b6 (diff)
downloadguix-6983b8a8264044c46fbd5c90a11152e2d2303e6b.tar.gz
gnu: strace: Update to 4.16.
* gnu/packages/linux.scm (strace): Update to 4.16.
[arguments]: Add phase to patch /bin/sh reference. New field.
[home-page]: Update to redirected URL.
-rw-r--r--gnu/packages/linux.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index cdeb8e92c7..5342c7f92e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -811,17 +811,25 @@ images more compressible.")
 (define-public strace
   (package
     (name "strace")
-    (version "4.7")
+    (version "4.16")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://sourceforge/strace/strace/" version
                                  "/strace-" version ".tar.xz"))
              (sha256
               (base32
-               "158iwk0pl2mfw93m1843xb7a2zb8p6lh0qim07rca6f1ff4dk764"))))
+               "1vzhmpcy989i4k12q4cc438yal2ghhm6x7ychscjbhcf2yspqj4q"))))
     (build-system gnu-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-/bin/sh
+           (lambda _
+             (substitute* "strace.c"
+               (("/bin/sh") (which "sh")))
+             #t)))))
     (native-inputs `(("perl" ,perl)))
-    (home-page "http://strace.sourceforge.net/")
+    (home-page "https://strace.io/")
     (synopsis "System call tracer for Linux")
     (description
      "strace is a system call tracer, i.e. a debugging tool which prints out a